top of page


Public·19 members

License Key Twonky 7

Hi, 2 weeks ago i purchased a new EX4100 and searched also for a guide to upgrade the installed twonky 7.2.9-13 to twonky 8.3. But there was no post to find in the web. So i tried it myself and succeed.The upgrade process is not difficult, but a little bit tricky.Some Linux experience would be an advantage.

License Key Twonky 7

You must create your own custom Firmware with the new twonky Version inside!But note: You have to purchase a twonky license key before you go on to work on this. Otherwise you are not able to activate twonky after Installation of your custom Firmware.

This guide can also be used for the DL4100 - but you must download the right Firmware and twonky sources because the DL devices are based on a different processor brand!The devices EX2100 and DL2100 and all MyCloud devices using FW 2.xx.xx can be updated the same way if a GPL source code package for the current firmware is available.

into SSH shell/etc/init.d/twonky stopcd /usr/local/twonkycp -a /usr/local/twonky /usr/local/twonkybackupwget Jira Service Managementunzip startreboot

You may need to be IN the twonkymedia-7 directory (or what ever directory is correct on the v2.x firmware) when you using the wget command and unzip the files otherwise the files may be unzipped into the wrong directory/location.

I deleted all the files into the twonky directory, and lunched the wget command within the same directory.The new files were into the right directory.The problem is after the reboot of mycloud

Need to do the same. Would you provide simple instruction for someone who has no idea of SSH? How to login via SSH?How to copy paste file to twonkymedia-7 folder?Appreciate really simple guide

Your choice, but maybe you should check if the commands really worked before going to the old one. Did you remove the directory before going to the v7? Did you stop the old twonky before installing the new one? If not, try to reboot. And add the output of:

Hi! By following your tutorial I could successfully run twonky yesterday. But while it was searching for media it froze and since then I could not restart it. Even though I stopped it and started it again from putty, I cannot connect with the browser. How can I check what happened? Thank you

HiTo undo this use Windows Explorer to connect to NAS1. Browse to X:\ffp\opt\twonky\data2. Edit file twonkyserver.ini in notepad3. Find in text minutesscantime=-1 and change to 04. Save file in top directory (do not rename)5. Login to sharecenter (http://)6. Go to Applications>Web file server7. Paste just edited twonkyserver.ini to X:\ffp\opt\twonky\data

About skipping the step, I doubt its possible unless you somehow modded the twonky on the TV. Ehat do you want to change about volume_1? the name? You can change its name by editing the samba conf files. There is no option in the dns-320 to change the name, but it is possible

I have successfully installed the Twonky Server kuro-box-pro-special-7.0.9 on DNS-325 as per the instruction. I am trying to purchase the license, but since I am windows user do I need to purchase TwonkyManager or TwonkyServer? Any help would be appreciated.

I installed twonky 7.0 to dns-323, and want to thank this site as perfect. works well, streaming to my wdtv and iphone/ipad. Now I want to buy a license, can you advice which one should i purchase, twonky manager or twonky server? thanks

Twonky is not willing to provide any support for products running on NAS even though I paid for the license so I decided to post here. I would appreciate any assistance in configuring Twonky server further and preventing it from opening this many connections to

Then do a reinstall:mkdir -p /ffp/opt/twonky/wget -TO-ZIPunzip twonky-*.ziprm twonky-*.zipchmod +x twonkyserver twonkystarter twonkyproxy twonkywebdav plugins/* cgi-bin/*wget -O /ffp/opt/twonky/twonkyserver-default.ini[[ $(ls -1 /mntgrep -c HD_a2) -eq 0 ]] && sed -i -e 's!/HD_a2!/HD/HD_a2!g' -e 's!/HD_b2!/HD/HD_b2!g' /ffp/opt/twonky/twonkyserver-default.ini

Hi have anybody solution to remove twonky. i need reinstall. if i make stop twonky it write no permission. delete any file from twonky folder ->no permision.i tried change permision with mc but no permission to change ? thx for reply

Directions worked for me. Environment is:DNS-320 firmware 2.03Twonky verson as example:7.0.11-special/twonky-kurobox-pro-special-7.0.11.zipServer discovers and displays on:Samsung UN32EH5300 smart TV

Archive: inflating: Linux-HowTo.txt inflating: radio.m3u inflating: inflating: TS_7.0_Release_Notes.pdf inflating: transcoding.html inflating: overview.gifunzip: cgi-bin/cgi-jpegscale: No such file or directory

How to know latest version ?Go to =2&t=7653Look at NAS versions, you have a link to 7x version, at this time it's -Special/Find in this list the "Linux PowerPC glibc 2.2.5" at this time it's -Special/

I did find it necessary to add one more step at the end of your instructions (perhaps due to the new Duo firmware version?):Edit the file /etc/nas/service_startup/twonky and change "disabled" to "enabled".[PS. I see this step will not be necessary with your latest script!]

BUT I've a problem in the WD My Book Live gui, in the multimedia section, under the enable/disable twonky option.Indeed, I don't see anymore the software's version, neither the number of files in each category (movie, music and pictures). There's nothing, it stays empty, even if I ask a re-analysis of the server.

Awesome tutorial. Thanks a lot, Dav-M. And here we go.No probs with upgrade. Also payed for twonky 7.But in generan nothing changed. Still no mkv over net.MBL+Samsung UE40ES6100.Maybe there is some issues with mime profile, but no idea what to improove:) Maybe next version of twonky will stream correctly.Or is it simple to fix in this version?Everything else perfect.

Hy Dav-M. Great job. Thx a lot! I upgraded succesfully yesterday and I tested a little bit my Samsung TV. All worked fine. But now I a problem appeared. The twonky has stopped and I have a licence error message: "Your trial version has expired. If you have previously entered a license key, try restarting your device running TwonkyServer." So i can do nothing in the moment, not even putting in my own bought twonky licence key now.

as to the issue of Fast Forwarding functionality when playing VOB filesI would suggest posting that question on the twonky community siteas this wiki thread is about installing and upgrading twonky on the wd mbl nasand it would be best to keep it that way, as to not stray to far off topic

I have MBL 1TB (02.42.02-012). I installed Twonky 7 (twonky-powerpc-glibc-2.2.5-7.2.1) and work fine with one problem :( Subtitle does not appear in my PS3. I tried subtitles in srt and txt format with film in avi and mkv format. Can you help?

Hello!Thanks a lot for the detailed instruction.Unfortunately, it didnt work out the way I wanter and I really need help.I ran all instructions at once and a problem occurred at one point.I started downloading the newer version but it didn't work. At the same time, the 5 version was moved to the folder twonky5old, and the newer version didn't install. I cant restart the twonky as it say that no file is found. When I try to download the 7 version to the /etc/local/twonky folder, it says "no space left on the device".Chmod to 777 didn't help. There is a lot of space available.Is there any way I can proceed to update or reverse the old 5 version?I am using putty for this, device WD MY BOOK LIVE.I do hope you can help me!!!! Thanks a lot in advance.

I was suppose (wrong) that in MBLD the switch name as change from twonky to another name, but if you have 'disabled' when you try to start then the switch name still twonky even if you don't have twonky in MBLD.

hi Dav-M,i'm newbie, i already try your step by step. until step 9, i try to play movie from samsung D5000 LEDTV,its ok . after that, i restart my BookLive , it's turn to 5.1.9, so i do step 2 to stop and step 10-12. and my twonky back again to 7.0.5, but my problem is :1. i play movie around 12-20second from my samsung tv, disconect. everytime.2. i already buy twonky 6, so my twonky is Full Version

Turns out I had two instances of twonkyserver running. I think this is because I'd ended up with both a script called "twonky" and one called "twonkysh" in /etc/initd (I hadn't read the instructions closely enough!)

Very interesting, but I highly doubt that this caused the problem on my Twonky. I copy/pasted all the instruchtions into my putty window and I notices that there are two commands in step 11. I would like to test it anyways, could you please tell me wether you removed the "twonky" or the "twonky(dot)sh" file?

/etc/init.d/twonky stop and start doesn't work eitherI tried to stop the server, delete everything in var/twonky and restart the server. Doesn't work.Tried the mv /usr/local/twonkymedia-5 /usr/local/twonkymedia-5old and reboot.Still see two Twonkys:

What's worth noting is that twonkystarter is a v7 script, so I we've got two instances of the new version running and what's also interesting is that one cluster has the webdav and proxy and the other doesn't. That makes me think one instance is started from /etc/initd/twonky and the other somewhere else. Could it be mionet or the mediacrawler? I've disabled Twonky at mionet's http: mybooklive site but I still have 2 instances fired up on reboot. 350c69d7ab


Welcome to the group! You can connect with other members, ge...
Group Page: Groups_SingleGroup
bottom of page